Gangmax Blog

自由之思想,独立之精神

Fix Apt Issue: Dependency Problems Prevent Processing Triggers for Shared-mime-info

| Comments

After I ran “apt-get dist-upgrade” and encountered an unexpecting exit, rerunning “apt-get dist-upgrade” gives me the following issue:

1
2
3
4
5
6
7
8
9
dpkg: dependency problems prevent processing triggers for shared-mime-info:
 shared-mime-info depends on libxml2 (>= 2.7.4); however:
  Package libxml2:amd64 is not configured yet.

dpkg: error processing archive /var/cache/apt/archives/oracle-java8-unlimited-jce-policy_8u121-1~webupd8~2_all.deb (--unpack):
 dependency problems - leaving triggers unprocessed
Errors were encountered while processing:
 /var/cache/apt/archives/oracle-java8-unlimited-jce-policy_8u121-1~webupd8~2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

The following solution comes from here:

1
2
3
4
5
# 1. Finish the unfinished configurating actions.
sudo dpkg --configure -a
# 3. In my case I run the following command to install
# the pacakges rather than "sudo apt-get install -f".
sudo apt-get dist-upgrade

Comments