Gangmax Blog

自由之思想,独立之精神

Error When Updating R on Ubuntu

| Comments

Today when updating R on Ubuntu, I got the following error:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-cran-codetools:
 r-cran-codetools depends on r-base-core (>= 3.2.2-1trusty0); however:
  Package r-base-core is not configured yet.
 r-cran-codetools depends on r-api-3; however:
  Package r-api-3 is not installed.
  Package r-base-core which provides r-api-3 is not configured yet.

dpkg: error processing package r-cran-codetools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-cran-foreign:
 r-cran-foreign depends on r-base-core (>= 3.2.2-1trusty0); however:
  Package r-base-core is not configured yet.
 r-cran-foreign depends on r-api-3; however:
  Package r-api-3 is not installed.
  Package r-base-core which provides r-api-3 is not configured yet.

dpkg: error processing package r-cran-foreign (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-cran-kernsmooNo apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
                                                                  No apport report written because MaxReports is reached already
    th:
 r-cran-kernsmooth depends on r-base-core (>= 3.2.1-2trusty0); however:
  Package r-base-core is not configured yet.
 r-cran-kernsmooth depends on r-api-3; however:
  Package r-api-3 is not installed.
  Package r-base-core which provides r-api-3 is not configured yet.
 r-cran-kernsmooth depends on r-cran-mass; however:
  Package r-cran-mass is not configured yet.

dpkg: error processing package r-cran-kernsmooth (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-cran-lattice:
 r-cran-lattice depends on r-base-core (>= 3.2.1-4trusty0); however:
  Package r-base-core is not configured yet.
 r-cran-lattice depends on r-api-3; however:
  Package r-api-3 is not installed.
  Package r-base-core which provides r-api-3 is not configured yet.

dpkg: error processing package r-cran-lattice (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-cran-matrix:
 r-cran-matrix depends on r-base-core (>= 3.2.2-1trusty0); however:
  Package r-base-core is not configured yet.
 r-cran-matrix depends on r-api-3; however:
  Package r-api-3 is not installed.
  Package r-base-core which provides r-api-3 is not configured yet.
 r-cran-matrix depends on r-cran-lattice (>= 0.12-11.1); however:
  Package r-cran-lattice is not configured yet.

dpkg: error processing package r-cran-matrix (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-cran-nlme:
 r-cran-nlme depends on r-base-core (>= 3.2.2-1trusty0); however:
  Package r-base-core is not configured yet.
 r-cran-nlme depends on r-api-3; however:
  Package r-api-3 is not installed.
  Package r-base-core which provides r-api-3 is not configured yet.
 r-cran-nlme depends on r-cran-lattice (>= 0.12-11.1); however:
  Package r-cran-lattice is not configured yet.

dpkg: error processing package r-cran-nlme (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-cran-mgcv:
 r-cran-mgcv depends on r-base-core (>= 3.2.1-4trusty0); however:
  Package r-base-core is not configured yet.
 r-cran-mgcv depends on r-api-3; however:
  Package r-api-3 is not installed.
  Package r-base-core which provides r-api-3 is not configured yet.
 r-cran-mgcv depends on r-cran-nlme; however:
  Package r-cran-nlme is not configured yet.
 r-cran-mgcv depends on r-cran-matrix; however:
  Package r-cran-matrix is not configured yet.

dpkg: error processing package r-cran-mgcv (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-cran-nnet:
 r-cran-nnet depends on r-base-core (>= 3.2.2-1trusty0); however:
  Package r-base-core is not configured yet.
 r-cran-nnet depends on r-api-3; however:
  Package r-api-3 is not installed.
  Package r-base-core which provides r-api-3 is not configured yet.

dpkg: error processing package r-cran-nnet (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-cran-survival:
 r-cran-survival depends on r-base-core (>= 3.2.1-3trusty0); however:
  Package r-base-core is not configured yet.
 r-cran-survival depends on r-api-3; however:
  Package r-api-3 is not installed.
  Package r-base-core which provides r-api-3 is not configured yet.

dpkg: error processing package r-cran-survival (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-cran-rpart:
 r-cran-rpart depends on r-base-core (>= 3.2.1-2trusty0); however:
  Package r-base-core is not configured yet.
 r-cran-rpart depends on r-api-3; however:
  Package r-api-3 is not installed.
  Package r-base-core which provides r-api-3 is not configured yet.
 r-cran-rpart depends on r-cran-survival; however:
  Package r-cran-survival is not configured yet.

dpkg: error processing package r-cran-rpart (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-cran-spatial:
 r-cran-spatial depends on r-base-core (>= 3.2.2-1trusty0); however:
  Package r-base-core is not configured yet.
 r-cran-spatial depends on r-api-3; however:
  Package r-api-3 is not installed.
  Package r-base-core which provides r-api-3 is not configured yet.

dpkg: error processing package r-cran-spatial (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-recommended:
 r-recommended depends on r-base-core (>= 3.2.3-3trusty0); however:
  Package r-base-core is not configured yet.
 r-recommended depends on r-cran-boot (>= 1.2.19); however:
  Package r-cran-boot is not configured yet.
 r-recommended depends on r-cran-cluster (>= 1.9.6-2); however:
  Package r-cran-cluster is not configured yet.
 r-recommended depends on r-cran-foreign (>= 0.7-2); however:
  Package r-cran-foreign is not configured yet.
 r-recommended depends on r-cran-kernsmooth (>= 2.2.14); however:
  Package r-cran-kernsmooth is not configured yet.
 r-recommended depends on r-cran-lattice (>= 0.10.11); however:
  Package r-cran-lattice is not configured yet.
 r-recommended depends on r-cran-mgcv (>= 1.1.5); however:
  Package r-cran-mgcv is not configured yet.
 r-recommended depends on r-cran-nlme (>= 3.1.52); however:
  Package r-cran-nlme is not configured yet.
 r-recommended depends on r-cran-rpart (>= 3.1.20); however:
  Package r-cran-rpart i
dpkg: error processing package r-recommended (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of r-base-html:
 r-base-html depends on r-base-core; however:
  Package r-base-core is not configured yet.

dpkg: error processing package r-base-html (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 r-base-core
 r-cran-boot
 r-cran-mass
 r-cran-class
 r-cran-cluster
 r-cran-codetools
 r-cran-foreign
 r-cran-kernsmooth
 r-cran-lattice
 r-cran-matrix
 r-cran-nlme
 r-cran-mgcv
 r-cran-nnet
 r-cran-survival
 r-cran-rpart
 r-cran-spatial
 r-recommended
 r-base-html
E: Sub-process /usr/bin/dpkg returned an error code (1)

First I thought it’s a problem of the source, but after I switched to another source the problem was still there. So I think it might be the problem in the package itself.

Comments